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Introduction
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Trinket may be small, but do not be fooled by its size! It's a tiny microcontroller board, built around the
Atmel ATtiny85, a little chip with a lot of power. We wanted to design a microcontroller board that was
small enough to fit into any project, and low cost enough to use without hesitation. Perfect for when
you don't want to give up your expensive dev-board and you aren't willing to take apart the project you
worked so hard to design. It's our lowest-cost arduino-IDE programmable board!

The Attiny85 is a fun processor because despite being so small, it has 8K of flash, and 5 1/O pins,
including analog inputs and PWM 'analog’ outputs. We designed a USB bootloader so you can plug it
into any computer and reprogram it over a USB port just like an Arduino. In fact we even made some
simple modifications to the Arduino IDE so that it works like a mini-Arduino board. You can't stack a big
shield on it but for many small & simple projects the Trinket will be your go-to platform.

Even though you can program Trinket using the Arduino IDE, it's not a fully 100% Arduino-compatible.
There are some things you trade off for such a small and low cost microcontroller!
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e Trinket does not have a Serial port connection for debugging so the serial port monitor will not
be able to send/receive data

e Some computers' USB v3 ports don't recognize the Trinket's bootloader. Simply use a USB v2
port or a USB hub in between

There are two versions of the Trinket. One is 3V and one is 5V. Both work the same, but have different
operating logic voltages. Use the 3V one to interface with sensors and devices that need 3V logic, or
when you want to power it off of a LiPo battery. The 3V version should only run at 8 MHz. Use the 5V
one for sensors and components that can use or require 5V logic. The 5V version can run at 8 MHz or
at 16MHz by setting the software-set clock frequency.

Here are some useful specifications!

e ATtiny85 on-board, 8K of flash, 512 byte of SRAM, 512 bytes of EEPROM

e Internal oscillator runs at 8MHz, but can be doubled in software for 16MHz

e USB bootloader with a nice LED indicator looks just like a USBtinylSP so you can
program it with AVRdude (with a simple config modification) and/or the Arduino IDE (with a
few simple config modifications)

e Mini or Micro-B USB jack for power and/or USB uploading, you can put it in a box or tape it up
and use any USB cable for when you want to reprogram.

o We really worked hard on the bootloader process to make it rugged and foolproof, this board
wont up and die on you in the middle of a project!

o ~5.25K bytes available for use (2.75K taken for the bootloader)

e Available in both 3V and 5V flavors

e On-board 3.3V or 5.0V power regulator with 150mA output capability and ultra-low dropout. Up
to 16V input, reverse-polarity protection, thermal and current-limit protection.

e Power with either USB or external output (such as a battery) - it'll automatically switch over

e On-board green power LED and red pin #1 LED

o Reset button for entering the bootloader or restarting the program. No need to
unplug/replug the board every time you want to reset or update!

e 5 GPIO - 2 shared with the USB interface. The 3 independent IO pins have 1 analog input and 2
PWM output as well. The 2 shared 10 pins have 2 more analog inputs and one more PWM
output.

e Hardware 12C / SPI capability for breakout & sensor interfacing.

e Mounting holes! Yeah!
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Guided Tour
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Let me take you on a tour of your Trinket! Each trinket is assembled here at Adafruit and comes
chock-full of good design to make it a joy to use.

e Mini-B USB connector - We went with the tried and true mini-B USB connector for power
and/or USB bootloading. In our experience, Micro-B connectors can rip off the PCB easily, but
we have not had that problem with mini B, its much more rugged for DIY electronics. It's also a
proper USB connector, so you can use any length cable. Some Attiny85 boards use a PCB that
slides into a USB port to cut costs, but that makes it hard to re-program and annoying to power
with an external battery pack

e Green Power LED - you'll know that the board is powered up when this bright LED is lit

e Red #1 LED - this LED does double duty. lts connected with a series resistor to the digital #1
GPIO pin. It pulses nicely when the Trinket is in bootloader mode, and its also handy for when
you want an indicator LED.

o Battery + Input - take your Trinket anywhere and power it from an external battery. This pin
can take up 16V DC input, and has reverse-polarity, over-curent and thermal protections. The
circuitry inside will use either the battery or USB power, safely switching from one to the other. If
both are connected, it will use whichever has the higher voltage

e USB Power Output - You can also snag the 5V power from the USB jack in case you need
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500mA+ current from your computer or portable USB power pack.

o Breadboard friendly pins - You can easily plug this into a little breadboard and have plenty of
space for working and plugging stuff in

e GPIO! - 5 GPIO pins, at 3 or 5V logic, check the next section for a detailed pinout guide

e 3 or 5V output - an onboard regulator provides 3.3V or 5V output for powering LEDs, sensors,
small motors, etc.

o Reset Button - an onboard reset button will launch the bootloader when pressed and the
Trinket is plugged into a computer. If it is not connected to a computer, it's smart enough to go
straight to the program.

o External Reset Pin - we bring out the reset pin so you can reset or restart your Trinket on the
road. If the Trinket is in a box or otherwise hard to get to, you can wire up a button to this pin for
an external reset button.

e Four mounting holes make it easy to attach with 2mm screws or even tiny zip-ties, string, etc.
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Pinouts
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The following shows measurements in mm, both version of the Trinket have the exact same
dimensions for hole placement & outline

Newer Trinket (Micro USB) dimensions

These are the same for the 3V and 5V versions
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Older Trinket (Mini USB) dimensions

These are the same for the 3V and 5V versions
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There are two versions of the Trinket: 3V and 5V. They are almost identical but there are slight
differences in the pinouts: one has a 3V output pin in the bottom right, the other has a 5V output
pin instead
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Here's the ATtiny85 pinout

[PCINTS/RESET/ADCO/dW) PBS L] 1 B [ ViCC
(PCINT3/XTAL1/CLKI/OCI1B/ADC3) PB3 [] 2 7 | PB2 (SCK/USCK/SCL/ADCT/TO/INTO/PCINTZ)
(PCINTAXTALZ/CLKOYOCIB/ADC2) PBA L] 3 6 |1 PB1 (MISO/DO/AINT/OCOB/OCTA/PCINTIT)
GND [] 4 5 |2 PBO (MOSI/DI/SDA/AINO/OCOA/OCT A/AREF/PCINTO)|
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Power Pins

We'll start with the top pins BAT+ and USB+ and GND

e BAT+ is the Battery + Input pin. If you want to power the trinket from a battery or power
adapter or solar panel or any other kind of power source, connect the + (positive) pin here! You
can connect up to 16V DC. If you have a 3V Trinket, you'll want at least 3.5V input to get a good
3.3V output. If you have a 5V trinket, 5.5V or higher is suggested. This input is reverse-polarity
protected.

e USB+ is the USB + Output pin. If you want to use the USB 5V power for something, like
charging a battery, or if you need more than 150mA of current (this pin can supply 500mA+
from USB ports) or to detect when the Trinket is plugged into USB, this pin will have 5V power
on it if and only if its plugged into something via the mini B connector

e GND is the common ground pin, used for logic and power. It is connected to the USB ground
and the power regulator, etc. This is the pin you'll want to use for any and all ground
connections

GPIO Pins

Next we will cover the 5 GPIO (General Purpose Input Ouput) pins! For reference you may want to
also check out the datasheet-reference above for the core ATtiny85 pin

All the GPIO pins can be used as digital inputs, digital outputs, for LEDs, buttons and switches etc.
They can provide up to 20mA of current. Don't connect a motor or other high-power component
directly to the pins! Instead, use a transistor to power the DC motor on/off (http://adafru.it/aUD)

On a 3V Trinket, the GPIO are 3.3V output level, and should not be used with 5V inputs. On a 5V
Trinket, the GPIO are 5V output level, and can be used with 3V inputs but may damage electronic
devices that are 3V input only!

The first 3 pins are completely 'free' pins, they are not used by the USB connection so you never have
to worry about the USB interface interfering with them when programming

e GPIO #0 - this is connected to PB0 on the ATtiny85. This pin can be used as a PWM output,
and is also used for 12C data, and SPI data input.

e GPIO #1 - this is connected to PB1 on the ATtiny85. This pin can be used as a PWM output,
and is also used for SPI data output. This pin is also connected to the onboard LED (like pin 13
on a regular Arduino).

e GPIO #2 - this is connected to PB2 on the ATtiny85. This pin can be used as an analog input
(known as Analog A1), and is also used for 12C clock and SPI clock.
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The next 2 pins are also used for USB programming. That means that when the Trinket is connected
to a computer and in bootloader mode or in the middle of uploading a new program, they are used for
sending data to/from the computer! It's possible to share these pins if you are careful. The best use of
these pins is as outputs to things like LEDs , or inputs to things like buttons and just make sure not
to press the buttons while connected to USB. We didn't want to keep these pins off the board but we
strongly recommend not using them unless you're sure you need them since you might have to
disconnect any connections to reprogram the Trinket!

e GPIO #3 - this is connected to PB3 on the Attiny85. This pin is used for USB programming, but
its also an analog input known as Analog A3
This pin has a 1.5K pullup to 3.3V built into the Trinket, for USB comm so it may be difficult to
use for analog or digital input.

e GPIO #4 - this is connected to PB4 on the Attiny85. this pin is used for USB programming, but it
can also be used as a PWM analog output and an analog input known as Analog A2

Note the numbering of analog pins: Pin 2 is Analog 1, Pin 3 is Analog 3, Pin 4 is Analog 2. For the
Uno, the terms A1, A2, and A3 are mapped for you. For ATtiny85's, they are not. So for the
pinMode calls, use the Pin number (stenciled on Trinket), for analogRead, use the analog
number.

Reset and Regulator Output

The final two pins are at the bottom of the board.

First is the Rst reset pin. This is connected directly to the ATtiny85's reset pin and also the reset
button which is right next to it. The reset pin is used to enter the bootloader and to reset the board in
case you want to restart it. It's also possible to use this pin to re-program in the bootloader or
completely remove the bootloader if you have an AVR programmer such as an AVR Dragon, MKii or
USBLinyISP. If you want to re-program the board when its in an enclosure or box or otherwise hard to
reach, wire a simple button from the RST pin to ground and press it to enter the bootloader for 10
seconds. The #1 LED will pulse to let you know. The reset button cannot be used as a GPIO, but we
think its a lot more useful as a proper reset button!

Lastly we have the regulator output pin. There is an onboard mini power regulator that will take up to
16V DC from the BAT+ or USB connection and regulate it down to a steady 3.3V or 5.0V DC so its
safe to use with your sensors and LEDs. On a 3V Trinket, this output will be about 3.3V. On a 5V
Trinket, this output will be 5V so be aware in case you want to swap one with the other. You can draw
up to 150mA output from this pin. If you need more current, you may want to get it directly from the
USB+ pin, which supplies 5V @ 500mA from a computer or wall adapter
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Starting the Bootloader
About the bootloader

A bootloader is a tiny piece of software residing on the microcontroller that that helps load your own
code into the remaining space.

One of the challenges with the Trinket is that we wanted to have a built-in USB bootloader, but the
ATtiny85 doesn't have built-in USB hardware! There are existing USB bootloaders that can work on
the 't85 but they use other companies' USB VID/PIDs. Since it not permitted by the USB developer's
group (http://adafru.it/cDW) to use others' VID/PIDs we had to adapt one of these existing bootloaders
to use our USB ID, but we also wanted to not have to re-compile avrdude or the Arduino IDE since
that's such a pain.

So instead, Frank (our awesome engineer with mad USB chops) (http://adafru.it/cDX) created a USB
bootloader that combines the elegance of V-USB with the well-supported and tested nature of the
USBLtinyISP. This bootloader looks just like a USBtinylSP - and since it uses the unique Adafruit
VID/PID we own and that we added to avrdude so long ago, it works with only very minimal
configuraton tweaks. No need to recompile anything, whew!

Please note: you cannot use the Adafruit USB VID/PID for your own non-Trinket products or
projects. Purchase a USB VID for yourself at http://www.usb.org/developers/vendor/

Trinket USB Drivers for Windows

If you're using Windows be sure to follow the Windows Driver Installation page (http:/adafru.it/jA9) to
install the appropriate drivers for your Trinket.

For Mac OSX or Linux you don't need to install any drivers.

Special Notes on using Trinket with
Linux

Trinket is not supported on Linux operating system at this time - try Mac OS or Windows!
However, you can try the following - it does work for some computers
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Linux is fairly picky about who can poke and prod at the USB port. You can always run avrdude or
Arduino IDE as root, which will make sure you have the proper permissions. If you want to be super-
cool you can add a udev rule which will let any user (who is not root) connect to the USBtiny driver.
That way you don't have to be root all the time!

Check http://learn.adafruit.com/usbtinyisp/avrdude#for-linux (http://adafru.it/cf3) for what to add to
your udev file.

How to start the bootloader

Before you try to upload code to the Trinket it must be in the Bootloader Mode. That means its
listening for a sketch or program to be sent to it

When the Trinket is in bootloader mode, the red LED will be pulsing. Once the red LED stops
pulsing, you must press the reset button to re-enter bootloader mode

The Trinket must be connected to a computer via a USB cable to enter bootloader mode. You can
enter the bootloader mode by pressing the little button on the board with your fingernail. The
bootloader will 'time out' after 10 seconds, so to re-enter the bootloader mode just re-press the button!

Don't press-and-hold the reset button, be sure to press-and-release!

See the video below for what it looks like to plug it in, have the LED pulse in bootloader mode, time out
and then press reset to restart the bootloader
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Windows Driver Installation

To use a Trinket, Gemma, or Flora on Windows you will need to install a driver for your board. Follow
the steps below depending on the board you're using:

e Adafruit Trinket/Gemma (black board) Driver Installation (http://adafru.it/jAa)
e Arduino Gemma (teal board) Driver Installation (http://adafru.it/jAa)
e Flora Driver Installation (http://adafru.it/jAa)

Note on Mac OSX or Linux you don't need to install any driver to use Adafruit's boards. Only
follow these steps if you're using Windows.

Adafruit Trinket/Gemma Driver
Installation

If you're using an Adafruit Trinket or Adafruit Gemma (the black circuit board Gemma, not the
teal or blue/green Arduino Gemma--for Arduino Gemma skip below to the next
section (http://adafru.it/jAa)) follow the steps below to install a custom driver for the board.

First download the signed Windows 10, 8, 7, Vista, XP driver below and unzip its contents to a folder
on your computer:

Download Signed Adafruit Trinket/Gemma Driver

http://adafru.it/djr

Remember this driver is for the Adafruit Gemma board and not the Arduino Gemma board. If
your Gemma has a black circuit board use this driver, but if it has a teal or green/blue circuit
board skip down to the next section.

If for some reason you need it there is also an older unsigned driver for Windows 7, Vista,
XP (http://adafru.it/eFa). Stick with using the signed driver above unless you know you need the
unsigned driver.

Then plug in the Trinket or Gemma to a known-good USB cable to start the process. You should see
the green power LED lit and the red bootloading LED pulse indicating that the Trinket is ready to start
bootloading. If you've programmed the Trinket since getting it, you can always get it back to the
bootloader state by pressing the small onboard reset button.

Finally, follow the steps on this page to install the custom Trinket/Gemma driver. (http://adafru.it/cDY)

If you're using Windows 10 you might need to follow the steps at the bottom of the page to manually
install the driver (http://adafru.it/jAa).
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Arduino Gemma Driver Installation

If you're using the Arduino Gemma (teal or blue/green circuit board, not the black circuit board
Adafruit Gemma--if you have a Adafruit Gemma skip back up to the
previous section (http://adafru.it/jAa)) follow the steps below to install a custom driver for the board.

First download the driver below and unzip it to a folder on your computer:

Download Arduino Gemma Driver

http://adafru.it/jAb

Remember this driver is for the Arduino Gemma board and not the Adafruit Gemma board. If
your Gemma has a teal or blue/green circuit board use this driver, but if it has a black circuit
board skip back up to the previous section.

Then plug in the Gemma to a known-good USB cable to start the process. You should see the green
power LED lit and the red bootloading LED pulse indicating that the Gemma is ready to start
bootloading. If you've programmed the Gemma since getting it, you can always get it back to the
bootloader state by pressing the small onboard reset button.

Finally, follow the steps on this page to install the custom Gemma driver. (http://adafru.it/cDY)

If you're using Windows 10 you might need to follow the steps at the bottom of the page to manually
install the driver (http://adafru.it/jAa).

Flora Driver Installation

If you're using the Flora board follow the steps below to install a custom driver for the board.
For Trinket or Gemma skip back up to the section at the top (http://adafru.it/jAa).

Begin by plugging in the Flora board. Look for a green power LED (left of the mini USB jack) and a
pulsing red LED (right of the mini USB jack).

WinXP users, skip down past these few photos, you should get a popup asking you for a driver
location, just browse to it as shown.

Windows 8 & 10

We now have signed Windows 8/10 drivers for flora. Download the driver by clicking here. You should
be able to right-click the inf file to install it directly, or point Windows to this uncompressed folder when
prompted!

If you're using Windows 10 you might need to follow the steps at the bottom of the page to manually
install the driver (http://adafru.it/jAa).
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Downloads the Windows XP/7/8 signed Flora Driver

http://adafru.it/dpT

Windows 7

You'll see this pop up in the bottom right corner:

“IL Device driver software was not successfully installed * *
Click here for details.

Now go to the Start menu (bottom left corner, the round windows logo) and click on it and start typing
in Device Manager

Control Panel (8)

|ﬂ Device Manager

L Manage audio devices

@ Yiew devices and printers

a Add a device
E Add a wireless device to the network

Documents (603)

ﬂ Guide_Troubleshooting.htrnl
& Guide Windows.html

& Guide_Environment.html
& Guide_ArduinoPreMini.html

Files (5)

% | KpsUsba.inf
£ | KpSwdm_wd.inf
& | Kps_pwdm.inf

| | usbasp.c

r' L
' 5ee more results

|dEl.r|'ce manal ® | | Shut down | ¥ |

Click on the Device Manager (top icon in the menu) to launch it, scroll down until you see Adafruit
Flora with a ! mark. Right click and select Update Driver Software
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U-Fj DD INPUT LEVICE
-¥= USBE Input Device
.= USB Input Device

ﬂgﬁ USE Input Device
=g IDE ATA/ATAPI controllers
i % Keyboards

[ ﬂ Mice and other pointing devices
: “-_i Monitors

- ¥ Network adapters

4 -3 Other devices

i ﬁ-‘ _Ad.a?uud—.:|m—r_..
: 1? Ports (C Update Driver Software...
B Pracessl Disable
>-® Sound, | Upinstal
0B8] Systern
-8 Univers: can for hardware changes
9 Scan for hard hang
|
Launches the Updat Peageite fice.

Locating the Driver File (Win 7 & XP)

OK if you have XP you'll basically start from here, click Browse my computer for driver software

i ¥
e

'.\::j 1l Updatg_?rh;e: Sﬂﬁwar_g,;}ﬂd;fr%}ty{l_ura

2|

How do you want to search for driver software?

< Search automatically for updated driver software
Windows will search your computer and the Internet for the latest driver software
for your device, unless you've disabled this feature in your device installation
settings,

Locate and install driver software manually.

| Cancel
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Then browse to the uncompressed Flora IDE folder, and select the drivers folder (not any other
folder!) and click OK.

File Action View Help _
& ME@m aid

A &3 L Update Driver Software - Adsfruit Flor

Browse For Folder W

Selert the folder that containg drivers for your hardware.,

[ srowse ]

4 L fNoral02
4 4 fore-102
a4 L drvers u puter
4+ . FTDIUSB Dri e, 2nd all drrver
L. amdbd
b BE6

o

ckrDa BwPE) L

(=1
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@ ' Update Driver Software - Adafruit Flora

Browse for driver software on your computer

Search for driver software in this location:

C\Users\ladyada'\Deskiop\floral02iflora-1.0. 2\ drivers - | Browse... I

Include subfolders

= Let me pick from a list of device drivers on my computer
This list will show installed driver software compatible with the device, and all driver
software in the same category as the device,

Mext ]I Cancel

Make sure the folder next to the Browse... button is correct, then click Next.

When you get this scary window next, click Install this driver software anyway.

<>
-

|

l!;ﬂ Windows Security

F?J Windows can’t verify the publisher of this driver software

Don't install this driver software
You should check your manufacturer's website for updated driver software
for your device,

Only install driver software obtained from your manufacturer's website or
disc. Unsigned software from other sources may harm your computer or steal |
information, |

(w) See details

That's it! Thankfully you only have to do this once.
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Windows 10 Driver Installation

If you're using Windows 10 the process to an install a custom driver is a little different than previous
Windows versions. When you plug in your device, like a Trinket/Gemma/Flora, you might not get a
pop up telling you to install a driver for the device. However you can follow the steps below to
manually install the driver.

These instructions show how to install the driver for a Trinket, but the steps should also apply to
Gemma and Flora (just expect to see a different name for the board).

First make sure you've downloaded the signed driver for the board from the sections above. Extract
the contents of the driver to a folder and remember where you put it.

Then plug in the Trinket/Gemma/Flora. You might hear a 'ding' from Windows that a new device
appeared but no dialog to install a driver. Don't worry keep following along to get the driver installed.

Now open Device Manager by clicking the start button and typing Device Manager, then clicking the
device manager result to run it. You should see something like the following:
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M S
4 Device Manager - 0 X
File Action View Help
= mHEm &

v | Tony-Windows|
& Audic inputs and outputs
¥ % Batteries
+ £} Bluetooth
M Computer
» & Disk drives
» B Display adapters
» &) DVD/CD-ROM drives
b g IDE ATA/ATAPI controflers
» § IEEE 1334 host controllers
» T4 Imaging devices
, = Keyboards
A Mice and other peinting devices
% Q Maodems
» B Monitors
» &P Metwork adapters
» = Print queues
» B Processors
» B 5D host adapters
» P Secunity devices
4 Sensors
¥ j Srnart card readers
» O Software devices
» iy Sound, video and game controllers l
» 4 Storage controliers
v M System devices

¥ ' Universal Serial Bus controllers

.-'F_.-."..' m:’ =

Press the bootloader button on the Trinket/Gemma and after a few moments you shoUId see device
manager refresh and display the board under an Other devices node:
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T e e
|§M:Mmgu = el
File Action View Help
e M E Hm & FSS

~ o Tony-Windows A
» &y Audio inputs and outputs
s 4P Batteries
» ) Bluetooth
» M Computer
s &p Disk drives
» B Display adapters
» &2 DVD/CD-ROM drives
s Ly IDE ATAJATAP| controdlers
5§ IEEE 1394 host controllers
s B Imaging devices
y == Keyboards
+ P Mice and other pointing devices
» & Monitors
» &¥ Network adapters

% m Print queues

» [ Processors

» W 5D host adapters

» [P Security devices

, [ Sensors

3 .'; Smart card readers ?
o Seftware devices

v % Sound, video and game controllers

+ €& Storage controliers

{8 System devices v

: = T —
Right-click the board (like Trinket in this example) and click the Update Driver Software... option at

the top. This should open a new dialog that looks like the following:
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™ e e —
i Device Manager = O X

_ File Action WView Help
e = |E B & RS
w g3y Tony-Windows e

" &= 1 Update Driver Seftware - Trinket

How do you want to search for driver software?

# Search automatically for updated driver software
Windews will search your computer and the Internet for the latest driver software
for your device, unless you've disabled this feature in your device installation

* settings.

< Browse my computer for driver software
Locate and install driver software manually.

-c;lﬂ':li

g e -

Select the Browse my computer for driver software option at the bottom. Now you should see a
dialog to find the driver like below:
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2 Dedica Manage: = O x
File Action View Help

:@!H!T?! B Hm & ERS

v = Tony-Windows

& [ Update Driver Software - Trinket

Browse for driver software on your computer
Search for driver software in this location:

A\ Users\ Tomy\Documents'irinket_driver v | Browse...

¥ Include subfolders

2 Let me pick from a list of device drivers on my computer

This fist will show installed driver software compatible with the device, and all driver
softwiare in the same category as the device,

[ an Cancel

} v mlﬂ!ﬂlﬂlukﬂm

E System devices H.

- ——— o 1!_:*;' ——

- - — x

Click Browse... and navigate to the folder where you unzipped the driver that was downloaded earlier.
Make sure the 'Include subfolders' option is checked so Windows is sure to find the driver. Then click

the Next button at the bottom.

You should see the driver installation start. During the installation you will probably see a pop-up like
below that asks if you want to allow the Adafruit driver to be installed:
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— I
-

g Device Manages = O
File Action View Help

| | R|EC HE & MRS

|

v = Tony-Windows

s

© [ Update Driver Software - Trinket

Installing driver software..

[7] Windows Security X

Would you like to install this device software?

Name: hbusb-win32 bush (WinUSB) devices
J Publisher: &dafrurt Industnes

[# Ahways trust software from “Adafruit Industries”, Install | | Don'tInstall

@ You should only install driver software from publishers you trust. How can | decide
which device software is safe to install?

POmE U YT LI T

M System devices

- — —m— . . — e
g L

Make sure Always trust software from "Adafruit Industries" is checked, then click Install.

The driver should finish installing. Note that you might see a "This device cannot start (Code 10)"

failure like the following:
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_—

=4 Device Manager

L |

File Action View Help
e DEHM S RS
| v g2 Tony-Windows ~

& || Update Driver Software - USBtiny

Windows encountered a problem installing the driver software for your device

Windows found driver software for your device but encountered an ermor while attempting to
nstall it

USBtiny
o

This device cannot start. (Code 10)

b\ S

If you know the manufacturer of your device, you can visit its website and check the support
section for drver software.

| Close

v -I.IH.HI LA L AT S

o [ System devices

S — SH -
Don't worry! This just means the Trinket/Gemma bootloader timed-out before the driver finished
installing. Everything should still be fine and you can continue along with the installation. Click Close

to finish the install.

Now device manager should show a libusb (WinUSB) devices node with the USBtiny device below
it:
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.
| 3 Device Manager

F!Il.‘ Action View Help
| m|E Hm & %S

v g Tony-Windows ~

» & Audio inputs and outputs

| 3 3P Batteries

» €) Bluetooth

» (M Computer

» & Disk drives

» B Display adapters

» &) DVD/CD-ROM drives

» Lg IDEATA/ATAP! controllers

» § IEEE 1394 host controllers

» 5 Imaging devices

» = Keyboards

v § libusb (WinUSB) devices

) .IJ hice and other pointing devices

» WE Modems

» I Monitors

> ¥ Network adapters

. 8 Print queues

> ﬂ Processors

+ I SD host adapters

s [P Security devices

s B Sensors *

> :: Smart card readers

> | Software devices

» & Seund, video and garme controllers
» &5 Storage controllers

+ (M System devices

,..-l"'L-.r—""...-_:""-_ - E e .
Don't worry if the device has an exclamation point next to it indicating a problem. Press the
Trinket/Gemma bootloader button and after a moment device manager should update to show the

device is working:
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_ e
| i Device Menages - o X

File Action View Help
@ |mE Hm & %S
v o= Tony-Windows ~
» & Audio inputs and outputs
» 3 Batteries
+ € Bluetooth
» M Computer
» & Disk dimves
K Display adapters
» &) DVD/CD-ROM drives
» £ |DE ATA/ATAPI controllers
» § IEEE 1394 hast controllers
» B Imaging devices
y =2 Keyboards
v i Iihuslh:rh_t"__w.i_rlldﬂajl devices

» ﬂ Mice and other pointing devices
» ] Modems

> *‘ Monitors

> ¥ Network adapters

» dm Print queues

> B Processors

> B SD host adapters

> [4% Security devices

> [ Sensors

> [3 Smart card readers

» | Software devices

» & Sound, video and game controllers
» €& Storage controllers

» M System devices v

That's it, your board should be ready to go and program with the Arduino IDE!
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ﬁ adafruit learning system

Setting up with Arduino IDE

Chances are, you picked up a Trinket because it is programmable with the Arduino IDE. Note that the
Trinket is not a full Arduino-compatible, it uses a different (smaller) chip than the Uno, Mega,
Leonardo or Due. However, there are many small sketches and libraries that will work just fine. Some
may not even need anything other than pin number changes.

Even though Trinket has a USB connector, it does not have a "Serial Console" capability, so you
cannot use Serial to send and receive data to/from a computer!

When you're ready to upload, make sure the "Programmer” in the Tools menu is set to
USBtinyISP!

Arduino IDE Setup

Just follow the steps in the steps in the Adafruit Arduino IDE setup guide (http://adafru.it/jAc) to
easily add support for Trinket, Gemma, Pro Trinket & more to the Arduino IDE.

When you're finished installing the IDE & board manager add on come back to this page to continue
the Trinket guide.

Blink!

After installing the Arduino IDE with support for Adafruit's boards you can load a simple blinking LED
example to test uploading to Trinket works as expected. Open the Arduino IDE and replace the sketch
code with the following blink code:

If you are using Linux you may have to be "root" running the Arduino program to have access to
the USB port (or add udev exceptions)

%

Blink
Turns on an LED on for one second, then off for one second, repeatedly.

This example code is in the public domain.

To upload to your Gemma or Trinket:
1) Select the proper board from the Tools->Board Menu
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2) Select USBtinyISP from the Tools->Programmer

3) Plug in the Gemma/Trinket, make sure you see the green LED lit
4) For windows, install the USBtiny drivers
5) Press the button on the Gemma/Trinket - verify you see
the red LED pulse. This means it is ready to receive data
6) Click the upload button above within 10 seconds

*/

/
intled = 1;// blink 'digital’ pin 1 - AKA the builtin red LED

// the setup routine runs once when you press reset:
void setup() {
// initialize the digital pin as an output.
pinMode(led, OUTPUT);

// the loop routine runs over and over again forever:
void loop() {

digitalWrite(led, HIGH);

delay(1000);

digitalWrite(led, LOW);

delay(1000);

Select the Trinket 8MHz board from the Tools->Board menu

GemmaBlink_8MHz | Arduing 1.0.5
| File Edit Sketch [Tuu[s Help
ﬁ@ @., 1 | Auto Format Ctri+T
' | Archive Sketch
GemmaBink. Fix Encoding & Reload
7 Serial Monitor Ctrl+ Shift+M 5
BElink | |
Turns on an Board k| Adafruit Gemma 8MHz
Senal Port I* @  Adafrut Trinket 8MHz
This examnpld
| Adafruit Trinket 160Hz
) Pregrammer 4
\ To upload of . . Arduino Uno

Then, select USBtinyISP from'the Tools->Programmer sub-menu
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Y
GemmaBlink_8MHz | Arduino 105 = B
File Edit Sketch E'I'auls] Help
Auto Format Ctrl+T
Archive Sketch
D Fix Encoding & Reload
i Serial Monitor Ctrl+ Shift+ M L
Blink
Turns on an Board p [ one second, repeatedly.
Serial Port 3
This examnpl igaa s
Prograrnmer r AVRISP
To upload t =
1] Select tl Burn Bootloader AVRISP mkdl
2) Zelect U3BtinyIAP from the Tools-=Programmsg @ USBtingISP
3) Plug in the Gemma/Trinket, make sSure you 36 USBasp
41 For windows, install the USEBtiny drivers Parallel P
5] Press the button on the GemmasTrinket - ver arafiel Frogrammer
the red LED pulse. Thiz means it iz ready o Arduino as ISP —
6] Click the upload button abowe within 10 seconds

Plug in the Trinket, make sure you see the green LED lit (power good) and the red LED pulsing.

Press the button if the red LED is not pulsing, to get into bootloader mode.

Click the Upload button (or select File->Upload)

p-

GemmaBlink_8MHz | Arduine 1.0.5

File Edit Sketch Tools Help

Upload

GemmaBlink_8MHz

FE
Blink

TTm

If evgrything goes smoothiy you should see the following (no red error messages) and of course, the
red LED on the trinket will blink on/off once a second
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GemmaBlink_8MHz | Arduino 1.0.5 ':'| (=]

File Edit Sketch Tools Help

GemmaBlink_SMHz

BElink -
Turrns on an LED on for one second, then off for one second, repeatedly.—

Thizs example code i3 in the public domain.

To upload to your Gemma or Trinket:
1) %Zelect the proper board from the Tools->Board Menu

m

21 Select T3BtinyISP from the Tools->Programmer

31 Plug in the Gemma/Trinket, make sure you see the green LED 1it

4] For windows, install the USEBtiny driwers

5) Press the button on the Gemma/Trinket - werify wou see N
the red LED pulse. This means it iz ready to recelwe data

6] Click the upload button abowve within 10 seconds

* 7

I

int led = 1; // blink 'digital'! pin 1 - AKA the built in red LED

A4 the setup routine runs once When you press resst: e

4] 1 |

Something Went Wrong!

If you get the error message avrdude: Error:
Could not find USBtiny device (0x1781/0xc9f)

That means the bootloader wasn't active. Make sure to press the button on the Trinket to activate the
bootloader before clicking the Upload button.

© Adafruit

. https://learn.adafruit.com/introducing-trinket Page 35 of 61
Industries



-

GemmaBlink_8MHz | Arduino 1.0.5 ':[| =]

File Edit Sketch Tools Help

GemmaBlink_SMHz
l,-'7r
Elink
Turns on an LED on for one second, then off for one second, repeatedly.

3

This example code i3 in the public domain.

m

To upload to wour Gemma or Trinket:

1) Select the proper board from the Tools->=Board Menu |
2] Select U3BtinyIi3P from the Tools->Programmer
3] Plug in the Gemma/Trinket, make sure you see the green LED lit — M

4] For windows, install the USBtiny drivers

5) Press the button on the Gemma Trinket - werify you see
the red LED pulse. This means it i8 ready to receiwve data

6] Click the upload button abowve within 10 seconds

int. led = 1; // blink 'digital' pin 1 - 4K& the built in red LED

If you get a lot of red text, errors and also a
warning about Verification Failed

Check that you updated the avrdude.conf file above - if you don't update the description of the
Attiny85 in the configure file by replacing it, the IDE wont know to be patient with the Trinket
bootloader and will have many upload errors
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| File Edit Sketch Tools Hel

GemmaBlink_SMHz

I Plug in the Gemma/Trinket, make sure you see the green LED lit
4] For windows, install the USEtiny driwvers
£ Press the button on the Gemma/Trinket - werify wou see
the ted LED pulse. Thisz meas it iz ready to receiwve data
6] Click the upload button abowe within 3 seconds

L
int led = 1; // blink 'digital' pin 1 - A4K& the built in red LED

A the setup routine runs once wheh ¥ou press reset:
vold setup ()
A4 dinitialize the digital pin as an output.
pinMode (led, OUTPIIT) ;

S the loop routine runs over and over agaln forever:
vold loop() {

digitalWrite(led, HIGH);

delaw(1000);

] T

Adafruit Trinket 2MHz on CO

On Linux if you get the error message
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"usbtiny receive: error sending control
message: Protocol error (expected 4, got -71)"

These can generally be ignored and should not interfere with the program upload. Unfortunately
Linux's USB core is a little flakey communicating with the ATtiny85 processor on the Trinket/Gemma
and can cause these errors. If an upload does falil, try it again as it is likely an intermittent issue.
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ﬁ adafruit learning system

Programming with Arduino IDE

Once you've gotten the basic Blink example to work, you can try some of the other Arduino functions
and libraries. We'll be filling out this section with more example code and links to tutorials - this is just
to get you started!

pinMode() & digitalWrite() & digitalRead()

You can use pinMode() to make inputs and outputs on any of digital pins #0 thru #4
digitalWrite also works well, and you can also use it with pinMode(INPUT) to activate the internal pull-
up resistor on a pin

For example, to set up digital #0 as an input, with an internal pullup, and then check if it is being pulled
to ground via a button or switch and turn on the red LED when it is pressed:

%

Button
Turns on an LED when a switch connected from #0 to ground is pressed

This example code is in the public domain.

To upload to your Gemma or Trinket:

1) Select the proper board from the Tools->Board Menu

2) Select USBtinyISP from the Tools->Programmer

3) Plug in the Gemma/Trinket, make sure you see the green LED lit

4) For windows, install the USBtiny drivers
)

5) Press the button on the Gemma/Trinket - verify you see
the red LED pulse. This means it is ready to receive data
6) Click the upload button above within 10 seconds
*/
#define SWITCH 0
#define LED 1

// the setup routine runs once when you press reset:
void setup() {
nitialize the LED pin as an output.

pinMode(LED, OUTPUT);

// initialize the SWITCH pin as an input.

pinMode (SWITCH, INPUT);

with a pullup
digitalWrite(SWITCH, HIGH);

}
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// the loop routine runs over and over again forever:
void loop() {
if (! digitalRead(SWITCH)) { //if the button is pressed
digitalWrite(LED, HIGH); //light up the LED

} else {
digitalWrite(LED, LOW); // otherwise, turn it off
}
}

analogRead()

You can read an analog voltage from digital #2 (called Analog 1), digital #3 (called Analog 3) and
digital #4 (called Analog 2)

For example, to read an analog voltage on pin #2, you would call analogRead(1) to read an analog
voltage on pin #4 call analogRead(2)

This is a bit confusing because the analog pins are numbered differently than the digital pins!

analogWrite()

There are a few PWM outputs on the Trinket, you can call analogWrite() on digital #0, #1 and #4.

For example, to pulse the built-in LED slowly, upload this code:

23

/
Pulse
Pulses the internal LED to demonstrate the analogWrite function

This example code is in the public domain.

To upload to your Gemma or Trinket:

1) Select the proper board from the Tools->Board Menu

2) Select USBtinyISP from the Tools->Programmer

3) Plug in the Gemma/Trinket, make sure you see the green LED lit

)

4) For windows, install the USBtiny drivers

5) Press the button on the Gemma/Trinket - verify you see
the red LED pulse. This means itis ready to receive data

6) Click the upload button above within 10 seconds

*/

/
intled = 1;// pulse 'digital' pin 1 - AKA the builtin red LED
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// the setup routine runs once when you press reset:
void setup() {
//'initialize the digital pin as an output.
pinMode(led, OUTPUT);
}

// the loop routine runs over and over again forever:
void loop() {

for (inti=0;i<256; i++) {
analogWrite(led, i); / PWM the LED from 0 to 255 (max)
delay(5);

}

for (inti=255; i>=0; i--) {
analogWrite(led, i); / PWM the LED from 255 (max) to 0
delay(5);

}

}

Make sure you're using the latest Trinket IDE so you can access pin #4's PWM capabilities. If you
aren't using the latest IDE you need to manually add functions like the following to init and write analog
values to pin #4. However if you have the latest IDE it includes fixes to make pin #4 usable with
Arduino's analogWrite function!

void PWM4_init() {

// Set up PWM on Trinket GPIO #4 (PB4, pin 3) using Timer 1

TCCR1 =_BV (CS10);// no prescaler

GTCCR =_BV (COM1B1) | _BV (PWM1B); // clear OC1B on compare
OCR1B = 127; // duty cycle initialize to 50%

OCR1C = 255;/

}

// Function to allow analogWrite on Trinket GPIO #4

void analogWrite4( duty_value) {

OCR1B = duty_value;// duty may be 0 to 255 (0 to 100%)
}

Wire (i2c)

You can use 12C with the Trinket! If you have our board manager package v1.6.4 or later (thats the
version of the trinket support package, not IDE) then Wire will work on Attiny85

On the Trinket boards, pin #0 is SDA (12C data), pin #2 is SCK (12C clock).

More...
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We also know the following libraries work:

e Adafruit NeoPixel (http://adafru.it/aZU) - control up to ~150 Neopixels via a Trinket!
e SoftwareSerial - the built in SoftSerial library can (at least) transmit data on any digital pin.
e More as we do more testing and verification!
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ﬁ adafruit learning system

Programming with AVRdude

For more technical users, rather than using the Arduino IDE, they may want to program the Trinket
directly with AVR-GCC as the compiler, vi/emacs as their editor and AVRdude as the uploader. That's
easy to do!

Target the Attiny85 as the chip used in avr-gcc, with F_CPU at 8MHz using the internal oscillator.

To use avrdude a minor change must be made to to avrdude.conf. To figure out where the
avrdude.conf is, open up a command window (windows: cmd, mac: Terminal, linux: rxvt etc) and
type in avrdude -v

m C:\WindD'.‘;S‘-;}-stem?,z'-{mdlexe

Cixlzerssladyada>avidude -v

avedude: Uersion 5.11.1, compiled on Oct 1 2812 at 13:18:15
Copyright ¢ 2000-2805 Brian Dean, http:/swww.bhdmnicro.comn/
Copyright ¢ 2087-2808%9 Joerg Wunsch

Syztem wide configuration File iz "C:sProgram Filesz (xB6>~MHU AUR Tools
“hin“avrdude .conf"

avrdude: no programmer has been specified on the command line or the config file

Specify a programmer using the =c option and try again

|

iIC=sUserssladyada >

e
Look for the line System wide configuration file is ..... thats where avrdude.conf is.

Because the USB bootloader is a little different than an off-the-shelf programmer, we have to update
the configuration file to have a longer erase delay. This does not affect programming bare Attiny85
chips, so you can use this configuration file with Trinkets or raw chips without any problems.

The Short Way

Download the new avrdude.conf by clicking on the button, rename the old avrdude.conf file to
avrdudeconf.bak and copy this new one into the same directory

Download the updated Trinket-friendly avrdude.conf

http://adafru.it/cDZ
A slightly different configuration file is needed for Mac:

avrdude.conf (Mac version)
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http://adafru.it/cEx
You can also find a Linux version of the avrdude.conf file here:

avrdude.conf (Linux version)

http://adafru.it/dXe

The Long Way

If you want to update your avrdude.conf by hand, its not too hard.

Open up that exact file in your favorite text editor

X avrdudeconf - XEmacs x|k
Fle Edt View Cmds Tools Options Buffers Help
A
MEEIEGRHEEEEERREE
Open | Dired | Sae Print cut Copy | Pas Undo Spell | Replace it Maws
avrdude.conf
$Id: avrdude.conf.in 1012 2011-09-15 14:57:51Z joerg wunsch § -%- text -*- il
AVRDUDE Configuration File i
This file contains configuration data used by AVREDUDE which deacribes
the programming hardware pinouts and also provides part definitions.
AVEDUDE's "-C" command line option specifies the location of the M
configuration file. The "-c" option names the programmer configuration
which must match one of the entry's "id"™ parameter. The "-p™ option "
identifie= which part AVREDUDE is going to be programming and must match 4
one of the parts"'" "id™ parameter. i
Poasible entry formats are: |
N
programmer i
id = £idl> [, <id2> [, <id3»] ...] : # «idN> are guoted strings
£ deac = Ldescription> ; $# quoted string
# Type = par | astkS00 | sckS00ve | sck00pp | stk500hvap | sthGﬂqenee:P ’
ic | ="
= T D L] B e s T 1 Fe bt =a R R i e
Raw-—%%i-HEmaca: ayrdude.conf (Texc PenbDel)-———Li--Top—— e
h‘..czading efs—cu...done I

and find the following text
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Raw-—-%%i-XEmacs:

flash_instr
egprom_instr

avrdude .conf

= OxB4, Ox02, Ox12;
= OxBB, OxFF, OxBB,
0xBC, 0x02, OxB4,

i [a vy ul (et}

OxEE, 0xBB, OxCC, O0xB2,
0x02, OxBA, 0x0OD, OxBB,

Man® ™

: Ty - — e o] S -
avrdude.conf - XEmacs
jﬂ i _ — —
File Edit View Cmds Tools Options Buffers Help
ﬁ )
DB B8 egaiﬁa@ﬁa
Open | Dired | Sae Prirt cut Copy | Pas Undo Spell | Replace nfa | Compis Mews
avrdude.conf
memory "calibration”
size = 2;:
read =" 0 1 1 i1 O 0 © 0DDDx x X x x",
" 0 0 0 o 0 0 a0 coge ooaa";
e e B e L L
‘#+ ATtinyss|
S
part —
id = ®mgg5™;
des=c = "ATtiny85";
has_debugwire = yes;

0x0D,
OxBC,

{(Texc PenDel Issarch)-——-L10BR0-—663-——————r=———x

:

I-search: atciny85

ours, that was ATmega640
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i T N
X avwrdude.conf - XEmacs |£I£ﬁ
| File Edit View Cmds Tools Options Buffers Help |
' - | | ABs | 2= |
Diw R S <lB BZ8|% E1 @ﬁ?
Open | Dired | Sam Print cut Copy | Paste | Undo Spell | Replace il nfo | Compils | Cebag | Mews
avrdude.cunf[
2ize = 2} :!
read = "3 0 I 1 1 0 0 0 00D x % x x x",
"0 0 0 O Q 0 aol Jo0aQQo o0oao";
BB e i ekt it et o Sl e o g .. .t .o i
# ATtinyEs
* ____________________________________________________________ |
B e e L e e e R L T R S LS
# ATmegat40
B e e L o e
# Almost same as ATmegalZzi80, except for different memory =sizes —:
part
id = "mGe40™;
desc = "AITMEGAG40";
signature = Oxle Ox9& OxCB;
has jtag = ye3; i
# gtk500 devcode = OxB2;
Ic3 w1 M Al - —_— (e A T =
{Raw--=~-KFmacs: avrdude.conf (Texc PenDel)——I110882—B1%~——————m—re——
N

Then paste in the following in the spot where you just deleted!

part
id = "t85";
desc ="ATtiny85";
has_debugwire = yes;
flash_instr = 0xB4, 0x02, 0x12;
eeprom_instr = 0xBB, 0xFF, 0xBB, 0xEE, 0xBB, 0xCC, 0xB2, 0x0D,
0xBC, 0x02, 0xB4, 0x02, 0xBA, 0x0D, 0xBB, 0xBC,
0x99, OxE1, 0xBB, 0xXAC;
## no STK500 devcode in XML file, use the ATtiny45 one
stk500 devcode =0x14;
## avr910_devcode = 7?;
## Try the AT90S2313 devcode
avr910 devcode = 0x20;
signature = 0x1e 0x93 0x0b;
reset =i0;
chip_erase_delay = 900000;

pgm_enable ="10101100 0101 0011"
IXXXX XXXX XXXX XXXX"

chip_erase ="10101100 100x xxxx",

© Adafruit

. https://learn.adafruit.com/introducing-trinket Page 46 of 61
Industries



XX XX XXXX XXXX XXXX"

timeout =200;
stabdelay = 100;
cmdexedelay = 25;
synchloops = 32;
bytedelay = 0;
pollindex = 3;
pollvalue = 0x53;
predelay =1;
postdelay = 1;
pollmethod = 1;

hvsp_controlstack =
0x4C, 0x0C, 0x1C, 0x2C, 0x3C, 0x64, 0x74, 0x66,
0x68, 0x78, 0x68, 0x68, 0x7A, 0x6A, 0x68, 0x78,
0x78, 0x7D, 0x6D, 0x0C, 0x80, 0x40, 0x20, 0x10,
0x11, 0x08, 0x04, 0x02, 0x03, 0x08, 0x04, 0x00;

hventerstabdelay =100;

hvspcmdexedelay = 0;

synchcycles = 6;

latchcycles

togglevig

poweroffdelay = 25;

resetdelayms =1;

resetdelayus = (0

hvleavestabdelay = 100;

resetdelay = 25

chiperasepolliimeout = 40;

chiperasetime  =900000;

programfusepolltimeout = 25;

programlockpolltimeout = 25;

memory "eeprom"”
size =512;
paged = No;
page_size =4;
min_write_delay = 4000;
max_write_delay = 4500;
readback_p1 = Oxff;
readback _p2 = Oxff;
read ="1010 0000 000x xxxa8",
"a7aba5a4 a3a2alal oooo0 0o000"

write ="1100 0000 000x xxxa8",
"a7ababa4 a3a2alta0 iiiiiiii"

loadpage lo="1 1 0 0 0 0 O 1"
"0O0OOO O0O0O 0"
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"0O0OO0OO O 0atao"
A
writepage="1 1 0 0 0 0 1 0"
"0 0 x x X X x a8",

"a7 a6 a5 a4 a3 a2 0 0,

X X X X X X X X%

mode = 0x41;
delay =12;
blocksize = 4;
readsize = 256;
memory "flash"
paged = yes;
size =8192;
page_size = 64;
num_pages = 128;
min_write_delay = 30000;
max_write_delay = 30000;
readback_p1 = Oxff;
readback_p2 = 0xff;
read_lo ="0010 0O O 0"
"0 0 0 O0attald a9 as8",
"a7 a6 a5 a4 a3 a2 al a0,

0O 00O OO O 01

="0010 100 0
"0 0 0 0 allal0d a9 a8",
"a7 a6 a5 a4 a3 a2 al a0l",

O 00O OO O 0

loadpage lo ="0 1 0 0 0 0 0 0
"0 00 x x x x x"
"X x x a4 a3 a2 al a0",

S T Y Y O T
loadpage hi ="0 1 0 0 1 0 0 0"
"0 00 x x x x x"

"x x x a4 a3 a2 al a0",

I T I Y B

writepage ="0100 1 1 00",
"00O0O0 al1al0a9 as",
"a7abab x x x x x",

X X X X X XX X"

mode = 0x41;
delay =6;
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blocksize = 32;
readsize = 256;
# ATtiny85 has Signature Bytes: 0x1E 0x93 0x08.
memory "signature"
size =&
read ="0011 0000 000 x x x x x"
"XxXxX xxalal oooo o000 0%
memory "lock”
size =1;
write ="10101100 111x xxxx",

min_write_delay = 9000;
max_write_delay = 9000;

3

memory "lfuse”
size =1;
write ="1010110010100000",

read ="0101 00000000 0000",
"X XXX XXXX 0000 0000"

min_write_delay = 9000;

max_write_delay = 9000;

3

memory "hfuse"”
size =1;
write ="101011001010 1000",

read ="0101 10000000 1000",
"XXXX XXXX 0000 0000";

min_write_delay = 9000;

max_write_delay = 9000;

3

memory "efuse"”
size =1;
write ="1010110010100100"
IXXXX XXXX XXXX XXXIi"

read ="0101 00000000 1000",
"XXXX XXXX 0000 0000";

min_write_delay = 9000;
max_write_delay = 9000;
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memory "calibration”

size =2;
read ="0011 1000 000X xxxXx",
"0000 000ad oooo oo000"

If editing manually, Mac users should delete all references to parallel port programmers ("type =
par;").

Uploading with AVRdude

Now you're ready to use avrdude. Open up your command line and enter in this line (but don't hit
return)

avrdude -c usbtiny -p attiny85

B C\Windows\system32iemd.exe

Cixlzerssladyada>avirdude —e ushtinyg —p attinyls

Now plug in the Trinket into the computer's USB port and/or press the reset button to enter the
bootloader. You should see the red LED pulsing. Now press return, you should get the same response
as shown here:
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i W
BN C\Windows\system3Z\emd.exe o [ S

C:slserssladyada>avrdude —¢ ushtiny —p attinudh

avrdude: AUR device initialized and ready to accept instructions
Reading | BRUBHHBHBNERBUEHNANERERHERANBRORHEHERNURRUBEBHERNE | 108 B.B2:

avedude: Device signature = Bxle?38b

Jlavrdude: safemode: Fuses OK

averdude done. Thank wou.

Cixlserssladyada

If you get the response
avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)

the bootloader is not active, make sure you see the red LED pulsing, press the reset button to start the
bootloader again.

Programming in a Blink example

For more details on using avdude and avr-gcc, you'll need to read a detailed tutorial or book on those
subjects. However, you can do a basic test by uploading the following HEX file, which will blink the #1
LED once a second on and off. (lts a bit chunky as blink.hex's go as it has all the Arduino IDE stuff in
there too. If you wrote it in straight-C it would be like 100 bytes) - if you want to see the source code
for this, it's basically the Arduino file->examples->basics->blink demo with 1 as the LED pin

Click the button to download it and place it in the same directory as your command prompt, in these
screenshots that's C:\Users\ladyada

http://adafru.it/cF1

And uploading it with the command avrdude -c usbtiny -p attiny85 -U flash:w:trinketblink.hex
or, if that's giving errors, avrdude -c usbtiny -p attiny85 -D -U flash:w:trinketblink.hex (note the
extra -D)

As before, type out the command, then press the reset button to start the bootloader and once the red
LED is pulsing, hit return

When uploading, you will see a lot of avrdude: 8 retries during SPI command and similar warnings.
THIS IS OK! Because of the way the ATtiny85 works, there's a small delay when writing the new
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program to flash, and during that delay, it cannot save the data and also send USB data at the same

time. Th|s causes the USB reply to avrdude to be delayed and avrdude to spit out the retry alert.

——

| Select C AWindows\sy ;‘tEBl;?',En'hd exe

Cixlzerssladvadaravirdude —¢ ushtinyg —p attinylds —-U flashiw:trinkethlink. hex
auvrdude: AUR device initialized and ready te accept instructions
Reading | HEHBHRHGHBHBHBRHGHBHBHBENERERERMRUEAHNBNBRUBHBHBHBENEE | 1608 B.82s

Device signature Bxle?idb
MOTE: FLASH memory haz been specified,. an erase cycle will bhe performed

To disable this feature,. specity the =D option.
verdude: erazing chip
vrdude: reading input file “trinkethlink.hex"

input file trinkethlink.hex auto detected as Intel He
vrdude: writing flash (832 bytes)

Writing | HEHE T B.Bdzavrdude 2

# retries during SPI command

Mriting | WHEREHEH 15¢ B.@8%9savrdude :

| 8 retries during SPI command

Uriting | HEHEHERBEEER 23 A.14zavrdude:

? retries during SPI command

Wreiting | HEHBRHEHBHUBHARY 38
8 retriez during SPI command

Writing | HEHEREEHERBUREHEHEN 8=
B retries during SPl command

Writing | ﬂﬂﬂﬂuﬂ#ﬂﬂﬂﬂﬁﬂﬂﬂﬂﬂﬂﬂﬂﬂﬂﬂ 46

8 retries during SPI command

Writing | HEHBUHUEHEHBHEHEHBERERERHENE 53

8 retries during SPI command

Meiting | HEHBRHRRERBABRHANERERBERBUBNRNY 61

8 retries during SPI command

Writing | BHESHERHEHBHERNERERBRE RS0 A0 0 b9

8 retries during SPI command

Writing | HEREGREREHRRBHNRERHERBRARNBHARERERHENR Thx

8 retries durding SPI command

Weiting | BEHBRURORBEHBRNBHERERHANBHBRBRBEHERBHBRUEY HE

8 retries during SPI command

triting | HHHEHERHEHERE RN ORI EE SRR R R BB 92

8 retriez during SPI command

Writing § HRESEHGEEHAHRESRER IR NG R R AR R S 188 B.62s

A8zaverdude =
Z2dsavrdude =
-2Bzsavrdude =
.d3savrdude =
-d?zavedude 2
-A2zavrdude :
LAzavrdude :

S2zavedude =

2 828 @ 2 2 8 3 2 @

LSPsavedode =

avrdude: 832 bytes of fFlash written

avrdude : verifying flash memnory against trinkethlink.hex:
avrdude: load data flash data From input file trinkethlink.hex:
avedude: input fFile trinketbhlink.hex auto detected as Intel Hex
averdude: input fFile trinkethlink.hex contains B32 hytes
avrdude: reading on—chip flash data:

Reading | HHHBRBHHBRBHSRARMEHEREHNBHENBRARHSHBRBHERURRBHEUTE | 166

avrdude: verifuping ...
vrdude: B32 bytes of flash verified

vedude: safemode: Fuses 0K

vrdude done. Thank wyou.

yeslserssladyada
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ﬁ adafruit learning system

16MHz vs 8MHz Clock

The Trinket by default runs at 8 MHz, a plenty fast speed for nearly all of your microcontroller needs.
However, you may want to use code that requires it to run at 16 MHz, or maybe you just want a little
boost in speed.

The 16 MHz clock speed for Trinket 5V only!

The ATtiny85 is only specified to run at 16 MHz when powered at 5V - that means that officially you
can only run the 5V Trinket at 16 MHz.

However, the AVR series is pretty forgiving for overclocking, so you may be able to run the 3V Trinket
at 16 MHz. Note that this is still overclocking, your code may run flakey or not at all! Overclocking
should not damage the AVR, but we still recommend sticking with 8 MHz only for the 3V version, and 8
or 16MHz only on the 5V version.

Power Tradeoffs

Doubling the speed will increase the power usage just a bit. At 8 MHz the current draw it about 9
milliamps. That number includes the green power LED which draws about 3mA so thats 6mA for the
microcontroller itself.

At 16 MHz the draw is 12mA total. Subtracting the green LED current draw, that means 9mA for the
microcontroller itself.

How to activate the 16 MHz clock
...on AVR-GCC

We can activate the 16MHz clock 'in software’ simply by asking the chip to set the clock prescale. If
you are using raw avr-gcc, run this as the first line in main()

clock_prescale_set(clock_div_1);

You may need to add #include to your file so that the commands are recognized. Then make sure to
compile your code with F_CPU = 16000000

...Arduino IDE

Using 16 MHz mode is very similar when using the Arduino IDE. Add the following line to the very top
of your Arduino sketch (as the first line)
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#include <avr/power.h>

Then, in setup() - add this as the first line in the function:

if (F_CPU == 16000000) clock_prescale_set(clock_div_1);

:Fhen select Trinket 16MHz from the Tools->Board menu. Your code will compile and run at 16 MHz!
@I GemmaBlink_16MHz | Arduina 1.0.5

File Edit Sketch [Tools| Help

Auto Format Ctrl+T
Archive Sketch
pmrasiie Fix Encoding 8 Reload
Senal Monitar Ctrl+Shift+M |
int led = 0; Nk
Board g Adafruit Gemma 8MHz
d4 th
> Rhsaen Serial Port | Adafruit Trinket BMHz
wold setup ()
¢/ This is @ Adafruit Trinket 16MHz
Programmer ]
Il Afoantnmari Archiinn [ han
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Repairing bootloader

The ATtiny85 does not have a protected-bootloader section. This means its possible to accidentally
overwrite the bootloader (or even if you unplug the Trinket while uploading it might have difficulties
from then on)

You can use an Arduino UNO to re-program the bootloader onto your Trinket (or Gemma). This loader
isn't tested to work with any other kind of Arduino.

Connect:

Trinket VBAT+ pin to Arduino 5V (or just power it via a battery or USB cable)
Trinket GND pin to Arduino GND

Trinket RST to Arduino #10

Trinket #0 pin to Arduino #11

Trinket #1 pin to Arduino #12

Trinket #2 pin to Arduino #13

On a Gemma, alligator clips work well. the Reset pin is underneath the MiniUSB Jack. You may have
to solder a wire temporarily. Alternatively, sometimes you can just hold the reset button down while
running the sketch (type 'G' to start) and it might work. Soldering a wire works best.

Then download, uncompress and run the Trinketloader sketch, pick the one that matches your
Arduino version!

trinketloader_2015-06-09.zip

http://adafru.it/fmg
Uncompress and open in the Arduino IDE, select the UNO and serial port to the UNO Arduino board
you are uploading too and upload it to the UNO.

Open up the serial console at 9600 baud and when it tells you do, press the miniature button on the
Trinket (or Gemma) or type in G into the serial console and click Send

You should see the following, the fuses, firmware burned and verified! It will take 2 seconds
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& e TE e

Trinket loader!

Type 'G" or hit BUTION for next chip
Starting Frogram Mode [OH]

Reading signatuare:3308

Bearching for image...
Found "blankfull.hex” for actinyss

Becting fuses Set Low Fuse to: Fl -> ADGD Set High Puse to: D5 -> ABOD Setc Ext Fuae to: 6 <> A400
Verifying fuses...

Low Fuse: OxFl iz OxFl

High Fuss: 0xD5 i O0xD5

Ext Fuae: 0x6 i3 Ox&

Sercing fuses

|
Verifing flash...

Flash verified correctcly!
Verifying fuses...

Fuses wverified correctly! L“
Iw! w
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Downloads
Datasheets

Datasheet for the onboard regulator used (MIC5225 3.3V and 5.0V) (http://adafru.it/dQO)

Webpage for the ATtiny85, the microcontroller used in the Trinket (http://adafru.it/cE5)

Windows Driver

Please note a driver is not required for Mac or Linux. And the driver does not appear as a 'COM' port!
It will show up as a 'USBtinylISP' device

USBtinyISP Windows XP/7/8 compatible

http://adafru.it/djr

Source code

Original code for the Trinket/Gemma bootloader on github (http://adafru.it/cE6)
We do not offer any support for this code, it is released as-is!

Please note: you cannot use the Adafruit USB VID/PID for your own non-Trinket/Gemma
products or projects. Purchase a USB VID for yourself at http://www.usb.org/developers/vendor/

Schematics

Click to embiggen
Trinket 3.3V Schematic:
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Trinket 5V schematic
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FAQ

I'd like to use Trinket with Linux....

We don't guarantee Linux support since Linux varies from distro to distro, but here's a very nice
tutorial about Trinket with Ubuntu 14) (http://adafru.it/dML)

| can't seem to upload to my Trinket when it's plugged into a USB 3.0 port (newer Macbooks have
USB 3 ports)

Trinket's bootloader is finicky about USB 3 ports, and might not work on them. Try connecting to any
USB 2 ports you have or go through a USB 1 or USB 2 hub (nearly all hubs are v2 or v1 instead of v3)
How come | can't find the Trinket Serial (COM) Port? Why is no Serial port found when the Trinket is
plugged in?

Trinket (and Pro Trinket) do not have a USB-serial converter chip on board, this is how we can make
them so small! Instead of a serial console, the Trinket is programmed directly over USB. No
COMY/Serial port is used at all!

My Trinket 16MHz can't control servos, NeoPixels, but the code is uploading OK?

Sounds like the Trinket thinks its running at 8MHz but the Arduino software thinks it's running at
16MHz, this causs timing-specific stuff like Servos and NeoPixels to not work. Don't forget you must
turn on 16MHz speedup if you are uploading to "Trinket 16MHZz"

Do so by adding

#include <avr/power.h>

At the very top of your sketch, and then

if (F_CPU == 16000000) clock_prescale_set(clock_div_1);
first thing in setup()

See more details here (http://adafru.it/jAd)

When uploading with the Arduino IDE, | get a lot of "(expected 4, got -5)" warnings and then "avrdude:
verification error; content mismatch"

Check that you followed the instructions for updating the Arduino IDE, including replacing the old
avrdude.conf (http://adafru.it/cEY)- this step is not optional!

Hmm I'm still having problems with Arduino/Avrdude - and | definitely did the required updates

One fix that works for some people is to edit avrdude.conf and set the

chip_erase_delay = 900000;

under the ATtiny85 heading to

chip_erase_delay = 400000;
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That is, a shorter delay.

Can Trinket driver Neopixels (strips, squares, etc)? How many?

Yes! Trinket was designed to drive short segments of NeoPixels. There is enough RAM on the attiny85
to drive 100 pixels, but depending on program RAM usage you may have to scale back to 60 or 40.

You can use EITHER the 3V or 5V Trinket, at EITHER 8 or 16MHz!

To use with neopixels:

1. Connect the + power line of the strip to VBUS (5V from USB), to VBAT if you are powering the
Trinket with 4-7VDC, or to a separate 4-7VDC power source such as a 3 or 4 pack of AA
batteries.

2. Connect the - common ground to the battery pack (if being used) and also to the Trinket GND
pin

3. Connect the data in line to Trinket #1 - this will let you also see when data is being sent because
the #1 red LED will flicker. You can use other pins but start with #1 since its easiest to debug
and use

4. Install the NeoPixel library as detailed in our Uber Guide (http://adafru.it/cEz), and change the
PIN to 1 (its 6 by default)

5. Upload and enjoy!

Can the Trinket drive your Adafruit 12C LED Backpacks for 7-segment/matrix displays?

Short answer: yes! Check out http:/learn.adafruit.com/tap-tempo-trinket (http://adafru.it/cEA) for a
tutorial on driving the 7-segment displays. Long answer: we think there's not enough space for all of
the fonts for the 8x8 so you might be able to drive the 8x8 matrix in 'raw' mode (see the HT16K33
example sketch in the LEDBackpack Library) but unfortunately not with built-in font support.

That tutorial also shows how to use the TinyM I2C driver, which works great on the ATtiny85, and
adapt other existing libraries for the Trinket

Can Trinket drive a Servo?

Yup! In fact you can use 3 servos as long as they are powered by a good 5V supply, check out this
guide for more details (http://adafru.it/cFC)

Why does Windows sound the Connect/Disconnect chimes every ten seconds?

The Trinket only appears to be a USBtinylSP device when the bootloader is running. By design, the
bootloader only runs for 10 seconds and then jumps back to the main user sketch. this causes the
'disconnect' sound.

On a new trinket, the main sketch will automatically jump back to the bootloader, which will then cause
the 'connect' sound. This cycle will repeat until a user sketch is loaded.

This situation can also happen if you load a sketch with a bug in it that causes a CPU reset.
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